View on GitHub


Flexe/PC-Lint (Plus) Integration for Eclipse CDT


To use Linticator, you first need to install a Lint from Gimpel. Second, Linticator requires an Eclipse Ganymede (3.4) release of the CDT and Java 1.6 or later, otherwise you won’t be able to install Linticator. To install Linticator, open the Install New Software wizard in Eclipse:

To install Linticator, please use the update site and select Linticator. If you have Eclipse CDT Helios (3.6) or newer, you can also check the Linticator Quickfixes. If you’re unsure what Eclipse version you have, you can try to install the Quickfixes and if Eclipse doesn’t complain, your version of Eclipse is recent enough.

After the installation, Eclipse will restart itself and a wizard will guide you through the configuration steps. The User Guide contains further explanations on how Linticator is configured.